PHP 7.1 compatibility

Tagged: 

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #68064 Reply
    Marco
    Guest

    PHP check compatibility detected some errors of OSM plugin with PHP 7.1 , so I’ve been waiting to update the PHP version.
    Those are the errors. Are they true or false?
    FOUND 8 ERRORS AFFECTING 8 LINES: an no longer be used in a plain function or method since PHP 7.1.
    54,55,793,794,816,817,255,258

    #68069 Reply
    – MiKa –
    Keymaster

    Hello Marco,

    thanks for your info.
    Could you provide the whole information / output?

    Thanks and Br, MiKa

    #68071 Reply
    Marco
    Guest

    This is the output of PHP check compatibility:

    FILE: /www.example.it/home/wp-content/plugins/osm/osm_map/osm-icon.php
    ———————————————————————————————
    FOUND 2 ERRORS AFFECTING 2 LINES
    ———————————————————————————————
    54 | ERROR | “$this” can no longer be used in a plain function or method since PHP 7.1.
    55 | ERROR | “$this” can no longer be used in a plain function or method since PHP 7.1.
    ———————————————————————————————

    FILE: /web/htdocs/www.bagnoliexplorations.it/home/wp-content/plugins/osm/osm_map/osm-oljs2.php
    ———————————————————————————————-
    FOUND 2 ERRORS AFFECTING 2 LINES
    ———————————————————————————————-
    793 | ERROR | “$this” can no longer be used in a plain function or method since PHP 7.1.
    794 | ERROR | “$this” can no longer be used in a plain function or method since PHP 7.1.
    ———————————————————————————————-

    FILE: /web/htdocs/www.bagnoliexplorations.it/home/wp-content/plugins/osm/osm_map/osm-oljs2_v4.php
    ————————————————————————————————-
    FOUND 2 ERRORS AFFECTING 2 LINES
    ————————————————————————————————-
    816 | ERROR | “$this” can no longer be used in a plain function or method since PHP 7.1.
    817 | ERROR | “$this” can no longer be used in a plain function or method since PHP 7.1.
    ————————————————————————————————-

    FILE: /web/htdocs/www.bagnoliexplorations.it/home/wp-content/plugins/osm/osm.php
    ——————————————————————————————
    FOUND 2 ERRORS AFFECTING 2 LINES
    ——————————————————————————————
    255 | ERROR | “$this” can no longer be used in a plain function or method since PHP 7.1.
    258 | ERROR | “$this” can no longer be used in a plain function or method since PHP 7.1.
    ——————————————————————————————

    #68076 Reply
    – MiKa –
    Keymaster

    Hello Marco,
    thank you for this info!!!
    We will provide an update in the beginning of next week.
    Br, MiKa

    #68081 Reply
    Marco
    Guest

    I’m looking forward to hearing from you.
    Marco

    #68168 Reply
    Marco
    Guest

    The problem is solved with the last upgrade. Now is compatible at least up to PHP 7.3 (according to PHP check compatibility).

    #68170 Reply
    Mi Ka
    Member

    Hello Macro,

    thanks for the feedback and the info!

    The plugin is free, but you can support us with your rate here:

    https://wordpress.org/support/plugin/osm/reviews/

    Thanks & br,
    MiKa

Viewing 7 posts - 1 through 7 (of 7 total)
Reply To: PHP 7.1 compatibility
Your information:




+ 33 = 34



By continuing to use the site, you agree to the use of cookies and load data from third parties. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close