Geotags werden nicht angezeigt

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #3618 Reply
    Carsten
    Guest

    Moin moin,

    ich versuche gerade die neue OSM-Anzeige für meine Geotags zu aktivieren. Die Geotags werden allerdings nicht angezeigt.
    Im Quelltext sind die Posts aufgeleistet.
    Das bedeutet: die Auswahl passt – nur die Icons werden nicht angezeigt.
    Hier eine Testseite:
    http://www.feuerwehren-stadt-bleckede.de/test/

    [osm_map_v3 map_center="53.278,10.741" zoom="11" width="99%" height="450" tagged_type="post" tagged_filter="Einsätze"]

    Wo liegt das Problem?

    Danke

    Gruß
    Carsten

    #3623 Reply
    – MiKa –
    Keymaster

    Hallo Carsten,

    kannst Du zwei Tests machen:

    1.) Caching Plugins und ähnliches ausschalten.
    2.) Einen Testbeitrag mit Geotag erstellen, mit der Kategorie Test und dann bei tagged_filter Test und nur diesen einen Beitrag anzeigen lassen.

    Br, MiKa

    #3631 Reply
    – MiKa –
    Keymaster

    Hallo Carsten,

    die geotags werden in den benutzerdefinierten Feldern abgespeichert, dh im Feld OSM_geo_data muss bei den Beiträgen der Wert für lat,lon stehen.
    Br, MiKa

    #3633 Reply
    Carsten
    Guest

    Guten Morgen,

    vielen dank für die Hinweise.

    Ich habe die Kategorie Test erstellt und nur einen post zugeordnet.

    Der Geotag sollte jetzt hier erscheinen:
    http://www.feuerwehren-stadt-bleckede.de/test/

    Im Quellcode ist dieser eine Geotag drin – aber nicht auf der karte.

    Ich habe Cachify abgeschaltet – keine Änderung. Jetzt habe ich die Testseite vom Caching ausgeschlossen.

    Ich habe in allen getagten Posts nur die Felder:
    OSM_geo_icon im Icon und
    OSM_marker_text mit lat/lon


    Test: Neues Feld OSM_marker_text manuell erstellt und lat/lon eingefügt:
    funktioniert!

    Warum wird das Feld OSM_marker_text bei neuen Posts nicht erstellt?
    Wie bekomme ich in den alten Posts (>400)
    OSM_marker_text zu OSM_geo_data konvertiert?

    Danke

    Gruß
    Carsten

    #3637 Reply
    – MiKa –
    Keymaster

    Hallo Carsten,

    kannst Du bitte ggfs korrigieren:
    * Die geotags sind manuell und nicht mit dem WP OSM Plugin tool “Shortcode generator” erstellt(das ist die Box beim Erstellen eines Beitrages, wo es auch den Tab [Set Geotag] gibt).
    * Das benutzerdefinierte Feld heisst OSM_marker_text und nicht OSM_geo_data

    Dann noch folgende Fragen:
    1.) Hat das Anzeigen aller Beiträge mit geotags schon einmal funktioniert, zB mit dem osm_map Argument? Wenn ja, hast Du einen Link dazu?
    2.) Wenn Du einen neuen Beitrage mit [Set Geotag] im “Shortcode generator” erstellst, wird dieser dann in der Karte (mit richtigem Filter) angezeigt – bitt einen Link.
    3.) Du schreibst: “Test: Neues Feld OSM_marker_text manuell erstellt und lat/lon eingefügt:funktioniert!”. Was hat funktioniert, kannst Du einen Link senden?

    Br, MiKa

    #3639 Reply
    Carsten
    Guest

    Moin moin,

    ich habe auf der testseite drei karten generiert … Antworten unten eingefügt:

    * Die geotags sind manuell und nicht mit dem WP OSM Plugin tool “Shortcode generator” erstellt(das ist die Box beim Erstellen eines Beitrages, wo es auch den Tab [Set Geotag] gibt).
    ==> Nein! Die Geotags sind in der (alten) Box und seit dem update unter dem aktuellen Reiter [Set geotag] erstellt worden

    * Das benutzerdefinierte Feld heisst OSM_marker_text und nicht OSM_geo_data
    ==> Das dabei generierte Feld mit lat/lon heisst in jedem Fall OSM_marker_text (ob in der alten Box oder unter [Set geotag] erstellt)

    Dann noch folgende Fragen:
    1.) Hat das Anzeigen aller Beiträge mit geotags schon einmal funktioniert, zB mit dem osm_map Argument? Wenn ja, hast Du einen Link dazu?

    Funktioniert immer noch (lange Ladezeit!):
    http://www.feuerwehren-stadt-bleckede.de/einsatze/einsatzkarte/

    [osm_map lat="53.294" lon="10.702" zoom="11" width="100%" height="800" import="osm_l" map_border="thin solid grey"]

    2.) Wenn Du einen neuen Beitrage mit [Set Geotag] im “Shortcode generator” erstellst, wird dieser dann in der Karte (mit richtigem Filter) angezeigt – bitt einen Link.

    Nein!
    http://www.feuerwehren-stadt-bleckede.de/test/
    Die erste Karte – Der Geotag wurde mit [Set Geotag] erstellt.
    Dabei erstelltes Feld: OSM_marker_text

    3.) Du schreibst: “Test: Neues Feld OSM_marker_text manuell erstellt und lat/lon eingefügt:funktioniert!”. Was hat funktioniert, kannst Du einen Link senden?

    Karte Nr 3 auf der Seite
    http://www.feuerwehren-stadt-bleckede.de/test/
    Geotag mit [Set Geotag] und ein weiteres Feld OSM_geo_data manuell erstellt. In das Feld die lat/lon Werte kopiert > funktioniert.

    Ich hoffe du verstehst, was ich meine …

    Danke

    Gruß
    Carsten

    #3661 Reply
    – MiKa –
    Keymaster

    Hallo Carsten,

    damit haben wir ein klares Fehlerbild. Wir wollen noch in dieser Woche eine Version mit einer Behebung veröffentlichen. Kannst Du uns bitte hier Deine e-mail Adress senden:

    http://wp-osm-plugin.hanblog.net/contact/

    Wir senden Dir eine Plugin Version, wenn von Dir dann das OK kommt, dass das Problem damit behoben ist, geben wir diese Version als neues Release Frei.

    Danke & lG, MiKa

    #3664 Reply
    Carsten
    Guest

    Danke – Mail ist raus …

    Gruß
    Carsten

Viewing 8 posts - 1 through 8 (of 8 total)
Reply To: Geotags werden nicht angezeigt
Your information:




44 − = 42



By continuing to use the site, you agree to the use of cookies and load data from third parties. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close