403 Forbidden – You don’t have permission to access post.php on this server

This topic contains 7 replies, has 2 voices, and was last updated by  Marcel 1 year, 9 months ago.

Viewing 15 posts - 1 through 15 (of 185 total)
  • Author
    Posts
  • #3285 Reply

    Andy

    Hi I have a similar problem to some earlier posts where I get the following error:

    You don't have permission to access post.php on this server.

    Unfortunately the workaround to change osm/osm-config-sample.php isn’t working for me. If I change OSM_enable_Ajax to FALSE, the OSM dialogue completely disappears from my post screen.

    Does anyone have any other options that could be tried. I will also see if I can get support from my web hosts, as i have also tried changing mod security settings to no avail.

    Thanks all in advance for any suggestions

    #3292 Reply

    MiKa

    Hallo Andy,

    you are right, this is not a fix but just disables the geotagging in the backend. But in fact you could still geotag your post just by adding the customfield “OSM_geo_data” with lat and lon address by yourself.
    For sure the better solution to check the permissions on your server.

    BTW: How did you get this problem? Did it happen with an update?

    BR, MiKa

    #3323 Reply

    Marcel

    I’m having same problem as Andy. After I’ve changed the workaround, the plugin disappeared from the blogpost page.

    Where do I add the customfield “OSM_GEO_DATA” to still geotag my post?

    (I have this problem since most recent update of OSM…)

    #3335 Reply

    admin01
    Keymaster

    Hello Marcel,

    we did not change anything “in this area” with the last update. Did you update only the WP OSM Plugin? If so, do you know from which version you updated it to the latest? We really would love to avoid this topics if it is on our side.

    You can find here some lines about geotagging the post directly in the custom field:

    http://wp-osm-plugin.hanblog.net/examples/display-geotagged-posts/how-to-geotag-post-pages-in-wordpress/

    Br, MiKa

    #3337 Reply

    Marcel

    An addition to my previous post: I just found out that if you want to geotag a post; it is not necessary to republish the original blogpost. You can just add the geotag on the small map to the right and press the save button.

    Next, my blog post was just shown on the ‘map’ I have on another page of the website. So at least, I didn’t need to use the custom fields.

    #3339 Reply

    Marcel

    Hi Mika,

    When I first had the 403-errors when posting a blogpost/page I only update the OSM plugin from 3.5.4 to 3.5.5.

    I thought this plugin was the problem, because of it was working again after deactivating the pluging or setting the OSM_enable_Ajax to FALSE.

    Grt

    Marcel

    #3349 Reply

    admin01
    Keymaster

    Hi Marcel,

    can you summarize? You set OSM_enable_Ajax to FALSE but you can still set the geotag with the widget (small map with SAVE button) when you write an post?

    Br, MiKa

    #3417 Reply

    Marcel

    Hi Mika,

    Apoligies, it must look a little confusing right now. Hereby a summary:

    *When OSM_enable_ajax = false I can’t use the plugin at all when making a page/blogpost. But, i don’t get the 403-error anymore with this setting.

    *When OSM_enable_ajax = true I get the 403-error when I try to publish or edit a blogpost or webpage. I also found out, when I use the small map on the right to geotag a post; I only have the save-button belowthe small map on the right. The post will be still geotagged, without the need to publish the post.

    *So when I want to make a blogpost with geotag, I first set the Ajax-setting to false and publish the post. Then I set the Ajax-setting to TRUE and add the geotag (with save button, and not publishing). I know, it’s a little complicated this way, but it works for me.

    I also asked my webhost if they can find something, because it’s really strange…

    #19293 Reply

    Jasonboant

    (Awaiting moderation)

    #19298 Reply

    Essaylow

    (Awaiting moderation)

    #19301 Reply

    EdwardBap

    (Awaiting moderation)

    #19303 Reply

    MichaelAposy

    (Awaiting moderation)

    #19748 Reply

    Mariananuh1992

    (Awaiting moderation)

    #19756 Reply

    Darrelgop

    (Awaiting moderation)

    #19757 Reply

    StaslEi

    (Awaiting moderation)

Viewing 15 posts - 1 through 15 (of 185 total)
Reply To: 403 Forbidden – You don’t have permission to access post.php on this server
Your information: